KB Article 15121
2016/03/04

Close
X
Contact Tech Support

 Email Tech Support
 (250) 655-1766
 [7:30 - 5:00 PST]
Your Meeting ID will be Provided by a Rep.
Tech Support
Tech Support Home
Software Updates
Knowledge Base Search
Recent KB Articles
Product FAQs
Code Samples
Documentation
Tech Blog
System Requirements
Installation Instructions
Support Testimonials
Contact us to...
Create a Ticket
Request a Free Demo
Suggest a New Feature
Submit Feedback
Upload a Large File
Other Services
Software Training
Professional Services

What licensed programs do I need to run WebSmart for Node.js?

Product: WebSmart Node Type: How to

You need to have the following licensed programs installed on your IBM i to run WebSmart for Node.js.

5733OPS IBM i Open Source Solutions

This includes:
Node.js runtime - Core Node.js runtime engine compiled to run in the PASE on IBM i
DB2 for i access library
Node.js toolkit for IBM i - This allows for access to IBM i systems resources such as system status, system values, job informations, message queue, object information, ILE programs and more.

 

Prerequisites:

IBM i V7.1+
5770SS1, option 33 PASE (Portable Application Solutions Environment)
5733SC1, option 1 OpenSSH, OpenSSL zlib functions, IBM Portable Utilities for i
5770DG1, *BASE-IBM HTTP Server for i

Rate This Article

Did this example help you to achieve your goal?
 Yes  No  Don't Know

Enter additional comments below.   If you want to hear back from us, include your contact information.

Email Address:
Comments:
Please enable JavaScript in order to rate this page.