KB Article 16365
2020/01/20

Close
X
Contact Tech Support

 Email Tech Support
 (250) 655-1766
 [7:30 - 5:00 PST]
Your Meeting ID will be Provided by a Rep.
Tech Support
Tech Support Home
Software Updates
Knowledge Base Search
Recent KB Articles
Product FAQs
Code Samples
Documentation
Tech Blog
System Requirements
Installation Instructions
Support Testimonials
Contact us to...
Create a Ticket
Request a Free Demo
Suggest a New Feature
Submit Feedback
Upload a Large File
Other Services
Software Training
Professional Services

How to fix JSON errors when using the new Presto Admin interface in a non-North American system/IBM i using Presto 8.3 / 8.4

Product: Presto Type: Troubleshooting

Presto 8.3 and 8.4 introduced the a new Admin interface to see who is logged into Presto, but there was a JSON error the prevented the UI from loading on some non-North American systems.  This should be addressed in release 8.5, but in the interim you can fix this by replaceing the LICSTAT program object in your Presto library.

You can download a save file containing the object here:
http://esdi.excelsystems.com/updates/presto/licstat.savf

If you FTP the save file to library QGPL you can restore it with the following command:
RSTOBJ OBJ(LICSTAT) SAVLIB(XL_PR77U11) DEV(*SAVF) SAVF(QGPLLICSTAT) RSTLIB(Presto_Library)

Once LICSTAT is restored you should have access to the new Admin interface.  For more information on the Admin UI check out KB#16218

Rate This Article

Did this example help you to achieve your goal?
 Yes  No  Don't Know

Enter additional comments below.   If you want to hear back from us, include your contact information.

Email Address:
Comments:
Please enable JavaScript in order to rate this page.